Weather Related Closure - Hendrick Honda Bradenton
Incident Report for Hendrick Automotive Group
Resolved
Hendrick Honda Bradenton is open for business.
Posted Oct 12, 2024 - 08:04 EDT
Investigating
Hendrick Honda Bradenton is currently closed in anticipation of Hurricane Milton.

Please check this Statuspage (https://status.hendrickauto.com) for information about the status of the office once the storm has passed.
Posted Oct 08, 2024 - 15:22 EDT
This incident affected: Announcements.