Slow Network - Mall of Georgia MINI
Incident Report for Hendrick Automotive Group
Resolved
Network connection has been restored.
Posted Nov 18, 2023 - 14:22 EST
Investigating
Mall of Georgia MINI is experiencing slow Internet speeds that are impacting web browsing, and applications that require Internet access such as ERA-Ignite. Our IT teams are addressing the issue and will provide updates as they are available.
Posted Nov 18, 2023 - 10:24 EST
This incident affected: Network Services.