Power Outage - Hendrick Collision Center HWY 55 Durham

Incident Report for Hendrick Automotive Group

Resolved

Power has been restored.
Posted Aug 14, 2025 - 14:05 EDT

Update

The power company has provided an ETR of 12:30pm. In the meantime, we have transitioned the network for the collision center to a temporary solution until power is restored.
Posted Aug 14, 2025 - 09:53 EDT

Identified

Hendrick Collision Center HWY 55 Durham is experiencing a power outage that is also impacting the local area. We will provide an update as more information becomes available.
Posted Aug 14, 2025 - 08:26 EDT
This incident affected: Building Operations.