Power Outage - BMW of McKinney

Incident Report for Hendrick Automotive Group

Resolved

Power has been restored and we've confirmed that all network devices and equipment are online.
Posted Mar 04, 2025 - 13:07 EST

Identified

BMW of McKinney is experiencing a power outage that is also impacting the local area. We will provide an update as more information becomes available.
Posted Mar 04, 2025 - 08:27 EST
This incident affected: Building Operations.