Power Outage - Multiple Dealerships in Pleasanton, CA

Incident Report for Hendrick Automotive Group

Resolved

Power was restored at the Pleasanton Auto mall around 2PM ET and has remained stable.
Posted Sep 11, 2025 - 16:43 EDT

Investigating

The following locations are experiencing a power outage that is also impacting the local area. We will provide an update as more information becomes available.

Impacted Locations:

Lexus of Pleasanton
Acura of Pleasanton
East Bay BMW
East Bay Mini
Posted Sep 11, 2025 - 13:31 EDT
This incident affected: Building Operations.