Partial Network Outage - Gwinnett Place Honda

Incident Report for Hendrick Automotive Group

Resolved

Network connectivity has remained stable at Gwinnett Place Honda.
Posted Oct 14, 2025 - 17:53 EDT

Monitoring

Network connectivity has been restored at Gwinnett Place Honda and we are continuing to monitor.
Posted Oct 14, 2025 - 14:53 EDT

Investigating

Gwinnett Place Honda is experiencing a partial network outage, due to flooding in part of the dealership that has impacted our on-site IT equipment. Our IT teams are assessing the issue, and we will provide updates as more information becomes available.
Posted Oct 14, 2025 - 08:34 EDT
This incident affected: Network Services.