Weather Related Closures – Winter Storm Enzo
Incident Report for Hendrick Automotive Group
Resolved
This incident has been resolved.
Posted Jan 24, 2025 - 12:56 EST
Update
The following locations will have delayed openings on Thursday ,1/23/2024:

• Southern Vehicle Accessories – Opening at 9 am on Thursday
• Greenville, NC - Opening at 10 am on Thursday
• Fayetteville, NC - Opening at 10 am on Thursday
• Jacksonville, NC - Opening at 10 am on Thursday
• Wilmington, NC - Opening at 10 am on Thursday
• Charleston, SC - Opening at 10 am on Thursday
Posted Jan 22, 2025 - 17:33 EST
Investigating
The following locations will have closures due to Winter Storm Enzo

• Southern Vehicle Accessories – closed today and Wednesday
• Stores in Tallahassee, FL – closing at 4 pm today and a delayed opening of 11 am on Wednesday
• Stores in Charleston, SC – closing at 4 pm today, closed Wednesday and a delayed opening of 10 am on Thursday
• Stores in Wilmington NC, and Jacksonville, NC – closing at 6 pm today, closed Wednesday and a delayed opening of 10 am on Thursday
• Stores in Fayetteville, NC – delayed opening tomorrow - TBA

Please check for updates on office statuses and subscribe to text alerts at http://status.hendrickauto.com
Posted Jan 21, 2025 - 12:13 EST
This incident affected: Announcements.