Power Outage - Rick Hendrick Chevrolet

Incident Report for Hendrick Automotive Group

Resolved

Power has been restored and we've confirmed that both dealerships are able to access the network.
Posted Jun 25, 2025 - 12:56 EDT

Identified

Rick Hendrick Chevrolet - Norfolk is experiencing a power outage that is also impacting the local area. This is also impacting network connectivity at Rick Hendrick Cadillac. At this time, the local power company estimating that power will be restored between 8am-1pm. We will provide an update as more information becomes available.
Posted Jun 25, 2025 - 09:08 EDT
This incident affected: Building Operations.