Power Outage - Multiple Locations in (Charlotte, NC)

Incident Report for Hendrick Automotive Group

Resolved

Power has been restored to the area.
Posted Aug 06, 2025 - 15:30 EDT

Identified

The following locations are experiencing a power outage that is also impacting the local area. We will provide an update as more information becomes available.

Impacted Locations:
Hendrick Automotive Group (Monroe Rd.)
Rick Hendrick City Chevrolet
Posted Aug 06, 2025 - 13:47 EDT
This incident affected: Building Operations.