Intermittent outbound phone calling issues - Multiple Sites

Incident Report for Hendrick Automotive Group

Monitoring

Activity has significantly decreased and we are no longer treating this as a major incident, though work on the underlying issue is ongoing. We are taking steps to prevent future disruptions in the meantime.

We will continue to monitor and will keep this posting active for the next 24 hours.
Posted Aug 18, 2026 - 13:50 EDT

Investigating

We have received multiple reports of problems with making outbound telephone calls and problems transferring calls. Our IT teams are aware and actively investigating. We will provide updates as they become available.
Posted Aug 17, 2026 - 12:47 EDT
This incident affects: Network Services.