Network Outage - Multiple Dealerships in (Hoover, AL)
Incident Report for Hendrick Automotive Group
Resolved
Network connectivity has been restored to all locations.
Posted Nov 20, 2023 - 10:01 EST
Investigating
The following locations are experiencing a network outage that is impacting telephones, Internet, and applications requiring network access. Our IT teams are addressing the issue, and we will provide updates as more information becomes available.

Impacted Locations:
Hendrick Chrysler Dodge Jeep RAM
Hendrick Chevrolet - Hoover
Posted Nov 20, 2023 - 07:49 EST
This incident affected: Network Services.