Power Outage - Hendrick Automotive Group Independence Center

Incident Report for Hendrick Automotive Group

Resolved

This incident has been resolved.
Posted Jul 06, 2026 - 11:02 EDT

Monitoring

Power had been restored. We are continuing to monitor until full service restoration is confirmed.
Posted Jul 06, 2026 - 10:10 EDT

Investigating

Hendrick Automotive Group Independence Center is experiencing a power outage. We will provide an update as more information becomes available.
Posted Jul 06, 2026 - 08:19 EDT
This incident affected: Building Operations.