Network Outage - Hendrick Acura Northlake

Incident Report for Hendrick Automotive Group

Resolved

The carrier has resolved the outage all services are functional.
Posted Aug 17, 2026 - 14:14 EDT

Identified

Our carrier has acknowledged the outage and is actively investigating the cause. There is currently no ETA for resolution. We will provide updates as more information becomes available.
Posted Aug 17, 2026 - 10:43 EDT

Investigating

Hendrick Acura Northlake is experiencing a network outage that is impacting telephones, Internet and applications requiring network access. Our IT teams are addressing the issue, and we will provide updates as more information becomes available.
Posted Aug 17, 2026 - 08:13 EDT
This incident affected: Network Services.