Microsoft 365 Services Outage

Incident Report for Hendrick Automotive Group

Resolved

Microsoft has resolved the issues and our Teammates should be able to access Outlook at this time.
Posted Mar 01, 2025 - 20:19 EST

Monitoring

Microsoft support identified an issue on their end that impacted our Teammates access to Microsoft 365 services such as Outlook and Teams. They have implemented a change and are continuing to monitor the status.
Posted Mar 01, 2025 - 17:12 EST

Identified

We have received reports that Teammates are having issues accessing some Microsoft services such as Outlook. This is outage is impacting multiple organizations and Microsoft support is working to resolve the issue. We will provide updates as they are available.
Posted Mar 01, 2025 - 16:43 EST
This incident affected: Corporate Email.