Power Outage - Hendrick Lexus Kansas City

Incident Report for Hendrick Automotive Group

Resolved

Power was restored this morning at approximately 9 AM ET and has remained stable.
Posted May 20, 2025 - 19:00 EDT

Investigating

Hendrick Lexus Kansas City is experiencing a power outage, as a result of inclement weather. We will provide additional updates as more information becomes available.
Posted May 19, 2025 - 18:10 EDT
This incident affected: Building Operations.