Network Outage - Cary Auto Mall

Incident Report for Hendrick Automotive Group

Resolved

Power and network connectivity have been restored at the Cary Automall.
Posted Dec 10, 2025 - 09:57 EST

Identified

The following locations are experiencing network outages due to a power / facilities issue. We will provide updates as they become available.

Impacted Locations:
Hendrick Buick GMC Cadillac
Hendrick Chevrolet
Hendrick Dodge Ram
Hendrick Kia of Cary
Posted Dec 09, 2025 - 20:54 EST
This incident affected: Building Operations and Network Services.