Autoguard Support Number Unreachable

Incident Report for Hendrick Automotive Group

Resolved

We have confirmed that the support numbers for Autoguard are now working.
Posted Mar 11, 2026 - 09:54 EDT

Identified

The issue has been identified and AT&T is working to resolve the issue.
Posted Mar 10, 2026 - 19:30 EDT

Investigating

We have received reports that customers are unable to reach Autoguard Customer Care via their support numbers. Our IT teams are investigating the issue and will provide more updates once they're available.
Posted Mar 10, 2026 - 12:42 EDT
This incident affected: Announcements.