Power Outage - Hendrick Collision Center of Concord
Incident Report for Hendrick Automotive Group
Resolved
Power has been restored at Hendrick Collision Center of Concord.
Posted Nov 08, 2023 - 16:07 EST
Investigating
Hendrick Collision Center of Concord is experiencing a power outage that is also impacting the local area. We will provide an update as more information becomes available.
Posted Nov 08, 2023 - 09:58 EST
This incident affected: Building Operations.