Multiple Sites - Undeliverable/DNS Errors Sending Emails

Incident Report for Hendrick Automotive Group

Resolved

This item was resolved through a configuration change and mail delivery has remained fully functional since.
Posted Aug 18, 2026 - 14:06 EDT

Monitoring

A workaround has been implemented and Teammates should be able to send external emails at this time.
Posted Aug 14, 2026 - 11:56 EDT

Identified

Our IT teams have identified an issue with our email gateway provider. We are working to resolve the issue and will provide more updates as they are available.
Posted Aug 14, 2026 - 09:14 EDT

Investigating

We have received multiple reports of Teammates receiving an Undeliverable message when sending out external emails. Our IT teams are aware and actively investigating. We will provide updates as they become available.
Posted Aug 14, 2026 - 09:11 EDT
This incident affected: Corporate Email.