Multiple Sites - Delayed External Emails & Scan to Email

Incident Report for Hendrick Automotive Group

Resolved

Microsoft confirms that this issue is fully resolved.
Posted Jun 03, 2026 - 17:31 EDT

Monitoring

Microsoft has reported that they are no longer seeing delays in sending and receiving email messages. They are continuing to monitor the issue as they implement their fix.
Posted Jun 03, 2026 - 08:37 EDT

Update

While emails are still partially delayed, we have seen an improvement in delivery times. Microsoft is continuing to work toward resolution.
Posted Jun 02, 2026 - 17:03 EDT

Identified

Teammates are reporting delays or failures sending and receiving emails, including items scanned to email. Microsoft is aware of the issue and is working to resolve it. We will provide updates as more information becomes available.
Posted Jun 02, 2026 - 13:38 EDT
This incident affected: Corporate Email.