Network Outage - Hendrick Chrysler Dodge Jeep Ram FIAT Wilmington

Incident Report for Hendrick Automotive Group

Resolved

Network connectivity has been restored and all systems are functioning normally.
Posted Sep 27, 2025 - 11:30 EDT

Investigating

Hendrick Chrysler Dodge Jeep Ram FIAT Wilmington is experiencing a network outage, following a power surge. Power is currently up at the dealership. We are attempting to re-route power to the networking equipment on-site. We will provide updates as more information becomes available.
Posted Sep 27, 2025 - 11:14 EDT
This incident affected: Network Services.