Multiple Sites - Unable to Scan to Email

Incident Report for Hendrick Automotive Group

Resolved

Scan to email is now working. Teammate are encouraged to retry any failed scans.
Posted Aug 16, 2025 - 12:43 EDT

Investigating

Teammates have reported issues when using the scan to email function. Our IT teams are investigating the issue and will provide more updates as we have them.
Posted Aug 16, 2025 - 09:10 EDT
This incident affected: Announcements.