Multiple Sites - Cloudflare Outage - Unable to Access Various Sites

Incident Report for Hendrick Automotive Group

Resolved

Cloudflare has resolved their outage and we've confirmed that websites are functioning properly.
Posted Nov 18, 2025 - 13:07 EST

Identified

Cloudfare is having Global Network issues that are impacting various websites that utilize their services. Below is a list of impacted websites used by our organization.

Reported Websites:
Car Wars
ChevyUSA
ChatGPT
Revolution Parts
Dealership websites

You can track the status of the outage at https://www.cloudflarestatus.com/
Posted Nov 18, 2025 - 09:49 EST
This incident affected: Announcements.