Power Outage - Rick Hendrick Chevrolet (Norfolk, VA)

Incident Report for Hendrick Automotive Group

Resolved

Power has been restored and network devices are back online.
Posted Aug 25, 2025 - 16:02 EDT

Identified

Rick Hendrick Chevrolet - Norfolk is experiencing a power outage that is also impacting the local area. We will provide an update as more information becomes available.
Posted Aug 25, 2025 - 13:37 EDT
This incident affected: Building Operations.