Network and Partial Power Outage - Jaguar Land Rover Charlotte

Incident Report for Hendrick Automotive Group

Resolved

Power has been restored at Jaguar Land Rover Charlotte and all systems are operational.
Posted May 13, 2025 - 15:56 EDT

Identified

Jaguar Land Rover Charlotte is experiencing a partial power outage and related network outage. We will update this incident as more information becomes available.
Posted May 13, 2025 - 13:47 EDT
This incident affected: Building Operations and Network Services.