Issues Logging into Executive Eye

Incident Report for Hendrick Automotive Group

Resolved

The login issues impacting Executive Eye have been resolved.
Posted May 12, 2025 - 13:14 EDT

Investigating

Teammates are reporting issues logging into and inputting information into Executive Eye. We are actively working with the software vendor, and we will provide updates as more information becomes available.
Posted May 12, 2025 - 11:26 EDT
This incident affected: Announcements.