Power Outage - Jeff Gordon Chevrolet

Incident Report for Hendrick Automotive Group

Resolved

Power was restored at approximately 7:40 am and systems are functional.
Posted Jul 13, 2026 - 08:05 EDT

Identified

Jeff Gordon Chevrolet is experiencing a power outage that is also impacting the local area. The power company is aware and is addressing. We will provide an update as more information becomes available.
Posted Jul 13, 2026 - 07:32 EDT
This incident affected: Building Operations.