Multiple Sites - Unable to Send/Receive Email

Incident Report for Hendrick Automotive Group

Resolved

Teammates have confirmed that they are able to send and receive emails normally.
Posted Jun 16, 2025 - 20:22 EDT

Update

Microsoft support has confirmed that all services are recovering following their mitigative actions. They are continuing to monitor recovery.
Posted Jun 16, 2025 - 19:58 EDT

Monitoring

Teammates have reported an issue with sending and receiving email. Microsoft has confirmed an issue impacting various Microsoft 365 services, including predominantly Microsoft Teams and Exchange Online. At this time, emails are being sent normally but there is a potential for intermittent delays. We will continue to monitor the issue and provide updates as they are available.
Posted Jun 16, 2025 - 19:28 EDT
This incident affected: Announcements.