Power Outage - Multiple Dealerships in (Pleasanton, CA)
Incident Report for Hendrick Automotive Group
Resolved
Power has been restored to the impacted locations. All network services are online.
Posted Nov 20, 2024 - 11:57 EST
Identified
The following locations are experiencing a power outage that is also impacting the local area. We will provide an update as more information becomes available.

Impacted Locations:
Lexus of Pleasanton
Acura of Pleasanton
East Bay BMW
East Bay MINI
Posted Nov 20, 2024 - 10:08 EST
This incident affected: Building Operations.