Power Outage - Southern Vehicle Accessories

Incident Report for Hendrick Automotive Group

Resolved

We have confirmed that power has been restored to Southern Vehicle Accessories and all equipment is operational.
Posted Apr 14, 2025 - 13:12 EDT

Identified

Southern Vehicle Accessories is experiencing a power outage that is also impacting the local area. We will provide an update as more information becomes available.
Posted Apr 14, 2025 - 08:12 EDT
This incident affected: Building Operations.