Power and Network Outages - Multiple Dealerships in Charlotte, NC

Incident Report for Hendrick Automotive Group

Resolved

Power and connectivity have been restored at the impacted locations.
Posted Jul 10, 2026 - 18:03 EDT

Investigating

The following locations are experiencing power and/or network outages caused by a power outage in the local area. Duke Energy has been notified and we will provide updates as more information becomes available.

Impacted Locations:

Jaguar Land Rover Charlotte
Hendrick Acura
Hendrick BMW
Hendrick MINI
Hendrick Porsche
Posted Jul 10, 2026 - 16:11 EDT
This incident affected: Network Services.