Multiple Sites - Unable to Login to eLead

Incident Report for Hendrick Automotive Group

Resolved

eLead reports and we have confirmed that the issues signing in have been resolved.
Posted Mar 14, 2026 - 16:54 EDT

Investigating

Teammates have reported issues signing into eLead. eLead support is aware of the issue and working on a resolution. For now they have recommended opening eLead in an incognito window which has worked for some people. We will provide more updates as we receive them.
Posted Mar 13, 2026 - 12:48 EDT
This incident affected: CRM.