Multiple Sites - Network Latency

Incident Report for Hendrick Automotive Group

Resolved

Network connectivity has continued to remain stable. All systems are functioning normal.
Posted Nov 23, 2025 - 14:54 EST

Monitoring

A temporary fix has been implemented and network traffic has resumed flowing normally. We are continuing to both investigate and monitor the issue.
Posted Nov 21, 2025 - 20:00 EST

Investigating

We are currently investigating new reports of latency and errors when accessing internal systems and applications. We will provide additional updates as more information becomes available.
Posted Nov 21, 2025 - 18:12 EST
This incident affected: Network Services.