Power Outage - Rick Hendrick Toyota Sandy Springs

Incident Report for Hendrick Automotive Group

Resolved

This incident has been resolved.
Posted Mar 11, 2026 - 14:51 EDT

Monitoring

We have confirmed that all network equipment is back online. We will continue to monitor and confirm the dealership is back up.
Posted Mar 11, 2026 - 12:20 EDT

Investigating

Rick Hendrick Toyota Sandy Springs is experiencing a power outage that is also impacting the local area. We will provide an update as more information becomes available.
Posted Mar 11, 2026 - 11:37 EDT
This incident affected: Building Operations.