Partial Network Outage - Hendrick Collision Center HWY 55 Durham

Incident Report for Hendrick Automotive Group

Resolved

We have confirmed that connectivity to Hendrick Wifi and Hendrick Guest have been restored.
Posted Mar 03, 2026 - 08:59 EST

Investigating

Hendrick Collision Center HWY 55 Durham is experiencing a partial network outage. While the primary network is operational, performance may be impacted. Other services, including the Hendrick WiFi and Guest wireless networks, and other miscellaneous devices are unavailable. Our IT teams are addressing the issue, and we will provide updates as more information becomes available.
Posted Mar 03, 2026 - 08:35 EST
This incident affected: Network Services.