Network Outage - Hendrick Lexus Charleston
Incident Report for Hendrick Automotive Group
Resolved
Network services at Hendrick Lexus Charleston have been restored.
Posted Sep 27, 2024 - 09:20 EDT
Investigating
Hendrick Lexus Charleston is experiencing a network outage that is likely as a result of Hurricane Helene. Our IT teams will continue to monitor and will provide updates as more information becomes available.
Posted Sep 27, 2024 - 08:46 EDT
This incident affected: Network Services.