Multiple Sites - Phone Call & Remote Access Latency

Incident Report for Hendrick Automotive Group

Resolved

This incident has been resolved.
Posted Nov 21, 2025 - 16:42 EST

Monitoring

Our Network team was able to identify and resolve the issue. Please try reloading the impacted applications.
Posted Nov 21, 2025 - 14:44 EST

Update

We are continuing to investigate this issue.
Posted Nov 21, 2025 - 10:28 EST

Investigating

Teammates have reported latency across several applications while working remotely. Additionally, they have reported call quality issues for inbound and outbound calls. Our IT teams are investigating the issue and we will provide updates as they are available.

Reported General Issues:
Scan to Email
Okta Login

Reported Remote Application Slowness:
Ignite
Cisco Finesse
Zscaler
Aruba Axis

Reported Call Quality Issues:
Receiving a busy tone on outbound calls
Customers unable to hear on inbound calls
Posted Nov 21, 2025 - 10:23 EST
This incident affected: Announcements.