Network Outage - Hendrick Honda Hickory
Incident Report for Hendrick Automotive Group
Resolved
Network connectivity has been restored for Hendrick Honda Hickory.
Posted Sep 29, 2024 - 19:58 EDT
Investigating
Hendrick Honda Hickory is experiencing a network outage that is likely as a result of Hurricane Helene. Our IT teams will continue to monitor and will provide updates as more information becomes available.
Posted Sep 27, 2024 - 08:37 EDT
This incident affected: Network Services.