Slow Network - Rick Hendrick Honda (Lakewood)

Incident Report for Hendrick Automotive Group

Resolved

This incident has been resolved.
Posted Mar 03, 2026 - 07:44 EST

Monitoring

We've received reports that Internet speeds have improved. We will continue to monitor and confirm resolution.
Posted Mar 02, 2026 - 10:24 EST

Investigating

Rick Hendrick Honda (Lakewood) is experiencing slow Internet speeds that are impacting web browsing, call quality, and applications that require Internet access such as ERA-Ignite. Our IT teams are addressing the issue and will provide updates as they are available.
Posted Mar 02, 2026 - 08:59 EST
This incident affected: Network Services.