Service Desk Phones Unavailable

Incident Report for Hendrick Automotive Group

Resolved

The Service Desk phone system has been restored. Teammates are now able to reach the Service Desk through any of our support numbers.
Posted Aug 05, 2025 - 09:10 EDT

Investigating

Teammates have reported being unable to reach the Service Desk through our support numbers. We are investigating the issue and working towards restoration. If you need to reach the Service Desk, please submit a ticket through the ServiceNow Employee Center icon in your Okta dashboard or email support@hendrickauto.com.
Posted Aug 05, 2025 - 08:47 EDT
This incident affected: Announcements.