Power Outage - Hendrick Honda & Hendrick BMW Certified Pre-Owned
Incident Report for Hendrick Automotive Group
Resolved
Power has been restored at Hendrick Honda and Hendrick BMW Certified Pre-Owned on South Blvd. in Charlotte, NC.
Posted Jan 09, 2024 - 16:08 EST
Investigating
Hendrick Honda and Hendrick BMW Certified Pre-Owned on South Blvd. in Charlotte, NC are experiencing a power outage, as a result of inclement weather in the area. The local power company has been contacted and we will provide updates as more information becomes available.
Posted Jan 09, 2024 - 14:42 EST
This incident affected: Building Operations.