Power Outage - Rick Hendrick Cadillac

Incident Report for Hendrick Automotive Group

Resolved

Power has been restored and the network equipment is back online.
Posted Jun 24, 2025 - 07:15 EDT

Investigating

Rick Hendrick Cadillac In Norfolk, VA is experiencing a power outage that is also impacting the local area. We will provide an update as more information becomes available.
Posted Jun 23, 2025 - 20:52 EDT
This incident affected: Building Operations.