eLead Internal Server Error

Incident Report for Hendrick Automotive Group

Resolved

This incident has been resolved.
Posted Jun 20, 2025 - 12:26 EDT

Monitoring

eLead support has indicated that the issue should be resolved. We will continue to monitor and confirm resolution.
Posted Jun 20, 2025 - 10:45 EDT

Investigating

We have received reports that Teammates are getting a "500 Internal Server Error" when trying to access eLead. Our IT teams are investigating the issue and will provide more updates as they are available.
Posted Jun 20, 2025 - 10:21 EDT
This incident affected: Announcements.