Hendrick Management Office - Delayed Opening
Incident Report for Hendrick Automotive Group
Resolved
This incident has been resolved.
Posted Sep 27, 2024 - 20:08 EDT
Investigating
Due to inclement weather conditions in the Charlotte area, the Hendrick Management Office will have a delayed opening today. At this time, we plan to open the office at 1030AM. Please use caution when traveling. If due to local conditions you feel you cannot safely make it to the office, you should contact your manager.
Posted Sep 27, 2024 - 07:23 EDT
This incident affected: Announcements.