Power Outage - Hendrick Chevrolet Cadillac
Incident Report for Hendrick Automotive Group
Resolved
Network connectivity has been restored to Hendrick Chevrolet Cadillac in Monroe.
Posted Jan 09, 2024 - 20:41 EST
Investigating
Hendrick Chevrolet Cadillac in Monroe, NC is experiencing a power outage that is also impacting the local area. The local power company has been contacted and we will provide an update as more information becomes available.
Posted Jan 09, 2024 - 16:10 EST
This incident affected: Building Operations.