Power Outage - Multiple Dealerships in (Pleasanton, CA)

Incident Report for Hendrick Automotive Group

Resolved

Power has been restored and all network devices are showing online.
Posted May 20, 2026 - 15:06 EDT

Identified

The following locations are experiencing a power outage that is also impacting the local area. We will provide an update as more information becomes available.

Impacted Locations:
East Bay BMW
East Bay MINI
Lexus of Pleasanton
Posted May 20, 2026 - 14:53 EDT
This incident affected: Building Operations.