Partial Network Outage - Hendrick Toyota Concord

Incident Report for Hendrick Automotive Group

Resolved

This incident has been resolved.
Posted Feb 10, 2026 - 09:57 EST

Monitoring

Teammates should now be able to connect to the wireless networks. We will continue to monitor until full resolution is confirmed.
Posted Feb 10, 2026 - 09:37 EST

Investigating

Hendrick Toyota Concord is experiencing a partial network outage. While the primary ethernet network is operational, Teammates have reported issues connecting to the wireless networks Hendrick Network, Hendrick Wifi, and Hendrick Employees. Our IT teams are addressing the issue, and we will provide updates as more information becomes available.
Posted Feb 10, 2026 - 08:41 EST
This incident affected: Network Services.