Power Outage - Multiple Dealerships in Pleasanton, CA

Incident Report for Hendrick Automotive Group

Resolved

Power remains stable at the Pleasanton Auto mall.
Posted Sep 10, 2025 - 16:23 EDT

Monitoring

Power has been restored at the Pleasanton Automall. Our teams are continuing to monitor the sites to ensure that power remains stable.
Posted Sep 10, 2025 - 10:45 EDT

Investigating

The following locations are experiencing a power outage that is also impacting the local area. We will provide an update as more information becomes available.

Impacted Locations:

Lexus of Pleasanton
Acura of Pleasanton
East Bay BMW
East Bay Mini
Posted Sep 10, 2025 - 10:31 EDT
This incident affected: Building Operations.