Network Outage - Hendrick BMW (Charlotte, NC)

Incident Report for Hendrick Automotive Group

Resolved

Network connectivity has been restored.
Posted Jun 26, 2025 - 09:04 EDT

Monitoring

Our Networking team has confirmed the network equipment has come back online. We are confirming with Teammates onsite that they are able to access the Internet and their applications requiring network access.
Posted Jun 26, 2025 - 08:30 EDT

Investigating

Hendrick BMW is experiencing a network outage that is impacting telephones, Internet and applications requiring network access. Our IT teams are addressing the issue, and we will provide updates as more information becomes available.
Posted Jun 26, 2025 - 07:43 EDT
This incident affected: Network Services.