Power Outage - Rick Hendrick Toyota Sandy Springs
Incident Report for Hendrick Automotive Group
Resolved
The power was restored at approximately 3:10 pm. All systems are up and remain stable.
Posted Sep 11, 2024 - 16:19 EDT
Investigating
Rick Hendrick Toyota Sandy Springs is experiencing a power outage that is impacting the area surrounding the dealership. We will provide an update as more information becomes available.
Posted Sep 11, 2024 - 14:17 EDT
This incident affected: Building Operations.